Support chat not available
Incident Report for LiveChat
Resolved
The issue had been identified and resolved - our support is available back again.
Posted 30 days ago. Nov 13, 2017 - 01:42 CET
Investigating
Support chat is not available at the moment. We are investigating the issue and working on bringing it back online
Posted 30 days ago. Nov 13, 2017 - 01:36 CET