Billing system issue
Incident Report for LiveChat
Resolved
We were notified that issues on our billing system provider end had been resolved, the subscription section is functional now.
Posted Feb 15, 2017 - 18:36 CET
Investigating
Our billing system provider has some major outage issues. Subscription page is not working properly - we are monitoring the issue.
Posted Feb 15, 2017 - 18:15 CET