Email delivery problems
Incident Report for LiveChat
Resolved
This incident has been resolved.
Posted 18 days ago. Oct 30, 2018 - 04:30 CET
Monitoring
We are monitoring status of the issue.
Posted 18 days ago. Oct 30, 2018 - 02:44 CET
Investigating
Our email delivery system provider is experiencing issues at the moment. Tickets and emailed reports may experience delivery delays.
Posted 18 days ago. Oct 30, 2018 - 02:38 CET