Website https://livechat.com is not operational
Incident Report for LiveChat
Resolved
This incident has been resolved. Our website is functional again.
Posted May 15, 2020 - 02:30 CEST
Investigating
We are currently investigating and working on resolving the issue. The main website https://livechat.com is at the moment unavailable.
Posted May 15, 2020 - 02:09 CEST
This incident affected: Support chat on www.livechat.com.